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Introduction 

Thank you for purchasing Remmon RLite GSM/GPRS RTU system. Please 
read this guide carefully to ensure proper installation.   

Remmon is committed for providing the best cellular interactive 

monitoring solutions for your business. If you need further assistance, 
please contact Remmon Remote Monitoring at remmon@remmon.com or 

visit our web site at www.remmon.com. For all contact information, see 
page 26. 

 

R-LITE Technical Specifications 

Table 1: Specifications for R-LITE 

Specifications 

Cellular Networks GSM. 

Cellular Modem TELIT 

Dimensions 9.0 cm (L) x 6.5 cm (w) x 2.6 cm 
(h) 

Power Requirements 12 VDC 

IO Cards 2   digital inputs 
1   1.0A/30VDC relay output 

Serial Connector RS232 

Environmental Requirements 

Temperature -25° - 55°C 

Humidity 5% - 95% 
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RLite LED 

RLite contains two LEDs on the front panel. Table  describes the PWR LED 

indications. 

Table 2: PWR LED Indications 

Description State 

Fast blinking, then 20 
second Off 

Initialization after reset 

Periodical Blinking: 2 
seconds On, ½ second Off  

Empty database – No project in 
RLite unit 

Periodical Blinking: ½ 
second On, 2 seconds Off 

Operational state 

Periodical Blinking: 1 
second On, 1 second Off 
and 5 fast blinks 

Connection state with PC 

Fast blinking Sending SMS 

Periodical Blinking: 1 
second On and 10 fast 
blinks. 

Pipe/Gateway state – Transferring 
data from PLC device to PC with 
cellular modem and vice versa. 
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Hardware Installation 

 

 

Figure 1: Back Panel Interface 

 

 

 

Figure 2: Front Panel Interface 

 

SIM Card 

To send and receive an SMS, you need a valid SIM card. 

Insert the SIM card into the SIM slot on the back panel, as shown in 
Figure 1. 

 

Antenna 

Plug in the GSM antenna by connecting the MMCX plug into the ANT 

socket. 
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Power Supply Cable 

Plug in the power plug into the power socket, as shown in Figure 1. 

RS232 Serial Cable 

The RS232 cable can either be used for connecting the RLite to a PC or to 
a PLC.  Using this cable you can program the RLite via your PC or you can 

read data from your PLC. 

To program the RLite via a PC, plug the RS232 cable into the RLite RS232 
socket and connect the other side of the cable (DB9 female connector) to 

your PC serial RS232 port.  

To connect the RLite to a PLC, plug the RS232 cable into the RS232 

socket, connect the other side of the cable to the RS232 female to male 
DB9 adapter, connect the other side of the adapter to the PLC.    

RJ12 Modular Cable 

Plug the RJ12 modular cable into the RLite RJ12 socket. Connect your 

application according to the following table. 

Table 3: RJ12 Pinout Information 

Socket Pin  Function Description 

1 GND Ground(-) 

2 Din 2 Digital input 2 

3 OUT a Relay's connector pole A 

4 OUT b Relay's connector pole B 

5 Din 1 Digital input 1 

 

6 NA Not Available  

Inputs Application 

The RLite comes with two Digital Inputs (Din1 and Din2) providing Dry 
Contact Interface DCI. Both inputs (Din1 and Din2) share the same 

common GND(-) contact. Each of these Dins (Digital Inputs) can be found 
in two states, Active ('1') or Inactive ('0'). Digital input is to be found in 

Active state if there is a contact between the GND(-) wire (pin number 6 
in the RJ12 connector) and the digital input wire. 

 

� Note: In the conditions statements, High and Low 
correspond to Active and Inactive states.  
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Relay output 

The RLite comes with one relay output. Relay output can be activated or 

deactivated either by setting a predefined condition or by sending an SMS 
message from a recognized mobile phone. Relay output is to be found in 

active state if OUT a (pin 3) and b (pin 4) are connected.  
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The Application Software 

Project 

An RLite project (or simply a project) is a computer file with an “rlt” 

extension. The RLite application software can either create a new project 
or open an existing one. A project is the RLite basic working environment. 

It is a platform, where you can edit your settings and download them to 
the RLite. When the project is set it can be downloaded to the RLite, thus 
configuring the RLite behavior. 

Creating a New Project: 

To create a new project: 

1. Click on File>New  

or click on the New project button    

The New project dialog box appears. 

 

 

Figure 3: New Project 

 

2. In the name textbox, type in a name for your project, 
choose a directory path and click on Next. 
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The Unit Definition dialog box appears. 

 

Figure 4: Unit Definition dialog-box 

3. Fill in the fields as described in the following table. 

Table 4: Unit Definition Descriptions 

Field Description 

Unit Model Click on the down-drop-list to select your RLite model. 

Unit phone Insert the unit phone number as ascribed to the SIM 

card in use. 

� Note: To configure the 
RLite unit via cellular 
modem, you must 
provide a valid phone 
number.  

Description Free text, describing your project. 

 

4. Click on Next 

The PLC and Communication Protocols dialog box appears. 
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Figure 5: PLC and Communication Protocol dialog box 

 

5. Fill in the fields, as described in the following table. 

Table 5: PLC and Protocol Field Descriptions 

Field Description 

PLC Type Select PLC protocol 

Scan period Select the period of time between the 

PLC's data scans by the RLite unit 

Baud Select baud rate for communication 

protocol with the PLC  

Parity Select Parity bit for communication 

protocol with the PLC 

DataLen Select Data length(Bits) for 

communication protocol with the PLC 

StopBits Select Stop Bit for communication 

protocol with the PLC 

 

6. Click on Next.  

A confirmation window, summing all the project configuration 

settings, appears.  

7. Review your settings  

8. Click on Finish. 
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Opening a Project: 

1. Click on File>Open  

or click on the Open project button    

The Open project dialog-box appears. 

2. Browse to the project directory, select your project and 

click on Open. 

 

� Note: To reopen a project, go to the menu bar and click on 
File>"project name".  

 

Viewing a Project's Properties:  

To view your project properties: 

1. On the menu bar, click on Project>Properties. 

2. Click on Next >Finish. 

New User(s) 

Users are the cellular phone subscribers who can control and receive 

messages from the RLite unit. To open the Users sheet page, click on the 
Users tab, on the vertical toolbar on the right of the screen. 

 



  RLite 

 

 10 

  

Figure 6: Users sheet page 

Adding a New User: 

1. To add new user click on the Add button. 

The Add user dialog-box appears 

2. Use the table below to set definitions for the new user. 

Table 6: User Descriptions 

Field Description 

User name The name of the user 

User Phone The phone number of the cellular 

phone to which messages are sent 

3. Click OK. 

� Note: You can add up to 16 users 

Changing/Deleting a User: 

You can either delete a user or change its properties. 

���� Deleting: Go to the Users sheet page, select the 
relevant user and click on Remove.  
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���� Changing: Go to the Users sheet page, click on Change. 
In the Modify user dialog box, change the user name or 
phone. 
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Working with Memory Fields (Tags) 

On the Memory page you can define I/Os, tags and other general purpose 

Bits which can be used as conditions within the RLite or with other 
controllers. 

To open the Memory page, click on the Memory tab, on the vertical 
toolbar at the right of the screen. 

 

 

Figure 7: Tags List 

Default Tags: 

The Memory tab contains default tag names, assigning tags to the RLite 
specifications, as described in the table below for model X1.  

Table 7: Default Tags 

Tag Description 

Din1 RLite's digital input 

Din2 RLite's digital input 
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Din3 NA 

Out RLite's Relay output 

Time RLite's time register 

Date RLite's date register 

DayOfWeek RLite's day of the week register 

PLC_COMM Communication regularity status: '0' 

for communication in order. 

'1' for communication abnormal 

 

� Note: Make sure that your PC time and date clock is 
correct. When downloading, the RLite clock 
automatically synchronized with your computer time 
and date clock. 

Adding a New Tag: 

1. Click on the Add button.  

The Add tag dialog-box appears. 

2. Use the table below to complete the dialog-box. 

Table 8: Tag Descriptions 

Field Description 

Name Tag's name which will be used for SMS feedback and reports 

Address Tag's address in the PLC 

Station PLC's Number  

Type Tag's type derived from protocol's properties 

Description General tag's description  

 

3. Click OK for adding this tag to the memory map. The new 

tag appears in the memory map list. 

 

� Note: You can add up to 100 tags. 
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Changing/Removing a Tag: 

1. Select the relevant Tag from the memory list. 

2. Click Change or Remove button. 

 

� Note: You cannot change or remove a system's 
default tags.  

� After you define, add or remove new tag, download 
the updated project information to the RLite unit 
(refer to Downloading or uploading a project) 
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Working with Conditions 

Setting conditions allows you to configure the behavior of your RLite on a 

given event. It is a logical mechanism through which you can specify 
events that will trigger sending an SMS. You also specify the recipient of 

the SMS, if output relay is going to be opened/closed, and more.  

To set a new condition, as well as modify an existing one click on the  
Conditions tab, on the vertical toolbar on the right of the screen. The 

Condition sheet page will appear. 

 

 

Figure 8: The Condition sheet page 

 

Adding a New Condition: 

1. Click on the Add button 

 the Add condition dialog box appears. 
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Figure 9: Condition Definition 

 

2.  Use the table below to set your condition.  

Table 9: Conditions 

Field Description  

Logical condition The logical expression, which 

determines when a warning is sent to 

the specified users. The expression 

consists of a Tag, operator, and a 

specific value (its type depends on 

the selected I/O type). 

I/O The I/O on which the condition is 

based. 

Note: The I/O drop down list contains 

some other items you may use as 

condition’s base (i.e.-time). 

Operator The operator of the logical 

expression. Possible values: 

= Equal to 
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the specific value. 

> Greater 

than the specific value. 

< Less than 

the specific value. 

     <> Not equal 

to the specific value. 

Value Select the value in the logical expression, 
its type and selection form depends on the 
selected I/O type 

Send SMS on alarm On Select SMS on alarm on for sending SMS 
in case of event/condition occurrence 

Send SMS on alarm Off Select SMS on alarm off for sending SMS 
in case of event's status inversion. 

SMS text Type text that is sent to the specified users 
cellular phones. 

 

3. For advanced properties click on the Advanced button.  

The Advanced properties dialog-box appears. 

 

 

Figure 3: The Advanced dialog-box 

4. Use the table below to complete the Advanced dialog-
box. 
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Table 10: Advanced Properties 

Field Description  

Stability time The amount of time during which the 

condition’s logical expression must be 

'true' before an SMS is sent. 

Send it: xx times The number of times the message will 

be sent to each recipient. 

Every :xx:xx The time passed between sending the 

messages. 

Out 1 Relay output activation by condition: 

Open for open relay contact. Close for 

relay contact. 

Wait stability time Mark this option in order to wait 

stability time. 

 

Attaching Values:  

To select any additional value(s) to be sent to your cellular phone with the 

text for this condition: 

1. Click on the Attach Values tab 

 

Figure 11: SMS Report 
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2. Click the value Name. A mark will appear next to the 
value, and the value will also appear in the Selected list. 

The Cellular screen window simulates how the condition message with 

its values will be displayed on your cellular phone. (The ### marks the 
parameters value digits). 

3. Click on OK.  

The new condition appears in the Conditions List. 

� Note: After defining a condition, you must associate 
users as recipients for the condition (refer to 
Associate users as conditions). 

� Note: After you defining conditions, download the 
updated project information to the RLITE.  

 

Changing/Removing a Condition: 

If you no longer want RLite to send warnings for a particular condition, 

you can delete the condition from the project. 

1. Select the relevant condition from the Conditions list. 

2. Click on Change or Delete button. 

 

� Note: After you changing or deleting any condition, 
you must download the updated project information 
to the RLite (refer to Downloading Data to an 
RLite). 
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Associating Users as Condition’s Recipients 

Recipients are the selected users that receive the conditions' SMS. 

Each condition may have its own selected recipients. 

 

 

Figure 12: Recipients Screen 

 
Selecting Condition’s Recipients: 

To reach the Recipient's screen,  

1. Click on the Recipient's tab on the vertical toolbar. 

2. Click the check box under the recipient's name which 
corresponds to the specific condition 

(Click again to uncheck it) 

 

� Note: After you select a condition’s recipients, 
download the updated project information to the 
relevant RLite (refer to Downloading Data to an 
RLite). 
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Downloading/Uploading  

Connecting with the RLite 

To upload or download a project, you must define your connection with 

the unit via the serial port of your PC or via a cellular modem. 

 

� Note: Ensure that the RLite's hardware is properly 
connected  

 

Defining a Connection: 

1. Click on Project > Connection 

 or click on the Setting button   

A Communication settings window will pop up 

 

Figure 13: PC Communication settings 

2. Select a communication method. 

If the communication is via serial port: 

• Select Via serial option 

• Select the correct serial port from the drop-down box 

• Select your port settings  

• Click on OK 

If the communication is via modem: 

• Select Via Modem option 

• Select Modem from the drop-down box 
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• Click on OK 

 
Remote Download: 

To support communication between RLite software and the RLite unit, a 
cellular modem needs to be connected to the PC that is running RLite 

software. 

 

� Note: Ensure that both the RLITE’s SIM and the 
PC’s modem’s SIM cards support CSD 
communication. 

� Note: If the RLITE’s SIM and the PC’s modem’s SIM 
are from different cellular service providers, use the 
DATA-IN number (the phone number for using the 
CSD) as the RLITE number in the RLITEs list on the 
Project Main screen.  
 
Your cellular service provider should enable the 
SIM cards for CSD, and inform you of their 
DATA-IN number. 

 
Setting up the Cellular Modem: 

Before installing the cellular modem in your PC, insert the SIM card into 
the modem so that the modem can transmit and receive data via the 

cellular network. For instructions regarding installation of the SIM card, 
refer to the modem’s documentation. The modem is connected to the PC 
with a 9 pin D-shell cable. 

To connect the modem to the PC: 

1. Connect the female end of the 9 pin D-shell cable to the 

PC that is running RLITE SOFTWARE 

2. Connect the male end of the cable to the cellular modem. 

 

Establishing a Connection with RLite Unit: 

1. Click on the Users tab on the vertical toolbar to open the 

Users List screen. 

2. Enter your password. 

� Note: For the initial connection to the RLite unit, 
enter the default password: 000000 (six zeros) 

3. Click on the Connect button   

4. Wait a few seconds. A green RUN indicator on the bottom 

left- of the screen will confirm your connection. 
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� Note: After establishing connection, you can change 
the password by typing a new six letter password 
and clicking on the Change password button 

 
Downloading a Project: 

After designing a project you must download the project to the RLite unit. 

 

� Note: Before downloading a project, make sure you 
have established a connection with the RLite unit. 

 

1. Click on the Download button   

2. Wait a few seconds till the download process is completed. 

 

� Note: After making changes to the project, it must 
be downloaded to the RLite unit to become valid. 

 
Uploading a Project: 

 

� Warning: Uploading data prom the RLite unit to an 
open project will erase all previous data on that 
project!!! 

In order to upload a project from the RLite unit you must open a project. 

1. Click on New project or open an existing one. 

2. Click on Upload button   

3. Wait a few seconds till the upload process is completed. 
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Using the RLite 

After a successful download you can put the RLite into work. Only users, 
which had been defined in the RLite configuration settings, can 
communicate with the RLite. A typical RLite user can either get warning 

SMS messages from the RLite or send inquiry/directive SMS messages to 
the RLite.        

Inquiries 

With the RLite in the field, you can check for the current value of each of 

its Tags. Each user, defined in the RLite configuration, can send an inquiry 
SMS message with the following format: 

?<Tag's name>, 

 

� Note: You may concatenate in one SMS, more than 
one request in the following format.  
? <tag name-1>,<tag name-2>, 

 

Examples: 

To get the current time of the RLite, send an SMS message to the RLite SIM card 

number with the following text:  

?time, 

To get the time and date of the RLite, send an SMS message with the following 

ftext:      

?time,date, 

To get the current value of digital input 1, send an SMS message with the 

following format:    

?<the name of digital input 1>, 

The default name for digital input 1 Tag is Din1; during RLite configuration one 

may rename some or all of the Tags. If the default name of digital input 1 hasn't 

been renamed, then a user may get its current value by sending an SMS message 

with the following text: 

?Din1, 

Directives 

With the RLite in the field, you can change or reset each of its Tags. Each 

user, defined in the RLite configuration settings, can send a directive SMS 
message with the following format: 

!<tag's name>=<value>, 



  RLite 

 

 25 

 

� Note: After RLite sets the new value, a notification 
message is sent to your cellular phone. 

� Note: You may concatenate in one SMS, more than 
one set command in the following format.  
!<Text-1>=<value-1>,<Text-2>=<value-2>, 

 

Examples: 

To set the RLite time to a specific hour, a user can send an SMS message to the 

RLite SIM card number with the following format:  

!time=HH:MM, 

To set the time to 16:30 the user should send SMS message to the RLite Sim 

card number containing the following text: 

!time=16:30 

To set the RLite date to a specific date, a user can send an SMS message to the 

RLite SIM card number with the following format:  

!date=dd.mm.yy, 

To set the date to August 11 2007 one should write 

!date=11.08.07, 

If it is now August 11 2007 and the time is 16:30, then one can set the time and 

date by sending the following SMS text: 

!Time=16:30,date=11.08.07, 

To turn on the output relay, send an SMS message with the following format:  

  

!<the name of the relay output>=1, 

The default name for the output relay Tag is Out; during RLite configuration one 

may want to rename some or all of the Tags. If the default name of the relay 

output hasn't been changed, then one may turn it on by sending the following 

SMS text: 

!Out=1, 

Alternatively, to turn off the relay output send the following SMS text: 

!Out=0, 
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